Delays in Crypto Transaction Processing

Incident Report for Altery

Resolved

The incident has been resolved.
Posted Oct 15, 2025 - 17:30 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 15, 2025 - 16:54 UTC

Identified

We’re currently seeing delays in crypto transaction processing due to an ongoing issue with our external service provider. Our team is actively monitoring the situation and coordinating with the provider to ensure a swift resolution.

All transactions remain secure, but confirmations may take longer than usual. We’ll provide updates as soon as more information is available.

If you have any questions or need assistance, feel free to contact us at support@altery.com or via Telegram @altery_supportbot. Thank you for your understanding!
Posted Oct 15, 2025 - 16:51 UTC
This incident affected: Payments (Add money from crypto, Send money to crypto wallet).