The earlier issue causing payment processing delays for some UK-based customers has now been resolved. Payments are being processed normally again, and status updates in the portal are displaying correctly. We’ll continue to monitor to ensure full stability. Thank you for your patience while we worked to restore normal service.
Posted Oct 23, 2025 - 18:56 UTC
Investigating
We’re currently experiencing payment processing delays affecting UK-based customers. As a result a number of payments may be temporarily delayed and status updates in the portal may not appear correctly. Our team is actively investigating the issue and working to restore normal service as soon as possible.
If you have any questions or need assistance, feel free to contact us at support@altery.com or via Telegram @altery_supportbot. Thank you for your understanding!
Posted Oct 23, 2025 - 17:21 UTC
This incident affected: Payments (Add money from bank, Send money to bank account).