The incident has been resolved. EUR bank transfers are processed as usual. Thanks for bearing with us!
Posted May 20, 2026 - 07:18 UTC
Investigating
We are currently experiencing delays in SEPA bank transfer processing. As a result, EUR bank transfers may take longer than usual to be credited or delivered.
Our team is actively monitoring the situation. We apologise for the inconvenience and appreciate your patience.
Posted May 19, 2026 - 15:47 UTC
This incident affected: Payments (Add money from bank, Send money to bank account).