SWIFT payments in local currencies might be temporarily unavailable for some customers

Incident Report for Altery

Resolved

The incident has been resolved.
Posted Jul 08, 2026 - 11:25 UTC

Identified

The issue has been identitifed and we're working on the resolution.
Posted Jul 08, 2026 - 07:22 UTC
This incident affected: Payments (Add money from bank, Send money to bank account).