SEPA transfers are processed with delay

Incident Report for Altery

Resolved

This incident has been resolved
Posted Jul 23, 2026 - 16:24 UTC

Identified

EUR transfers to/from Europe are processed with a delay. We're working on fixing the issue.
Posted Jul 23, 2026 - 11:44 UTC
This incident affected: Payments (Add money from bank, Send money to bank account).